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Abstract

Characterizing the chemicals within individual cells is an important analytical capability, with mass spec-
trometry (MS) being one of the most chemically information-rich techniques available. There are two
major approaches for characterizing single cells using MS: the assay of small-volume solutions using
electrospray ionization and, the focus of this chapter, measurement of cells dispersed across a surface
using matrix-assisted laser desorption/ionization (MALDI) MS. In combination with spatiometric infor-
mation obtained via optical imaging tools to locate individual cells on the sampling surface, follow-up
measurement via MALDI MS can profile a multitude of single cells in a high-throughput manner.
Compared to conventional MS imaging of the entire sample-containing surface, preselection of accurate
cell locations for targeted analysis increases selectivity and throughput as well as reduces overall data size. As
a result, more informative data sets are produced in less time with fewer resources. Employing this strategy,
we present a multistage protocol for optical image-guided, high-throughput single cell analysis by MALDI
MS. We outline steps for the isolation and preparation of single cells prior to dispersing on a glass slide for
optical imaging, automated mapping of imaged cell locations using microMS, preparing the cells for
MALDI MS analysis using standards and MALDI matrices, acquisition of mass spectra from mapped
individual cells, and data processing and statistical analysis. Images obtained via a range of microscopy
modalities can be assessed by the microMS custom image processing software suite to determine location
coordinates for cells with defined morphological and/or biochemical characteristics. Depending on the
biological model and MS instrumentation used, this strategy can be further enhanced by hyphenation of
different imaging modalities, e.g., electron microscopy, for multidimensional sample characterization.

Key words Single cell, MicroMS, Mass spectrometry, Pancreatic islets, Peptides, Microanalysis, High
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1 Introduction

Arguably, the cell is the most fundamental unit of life and possesses
a variety of the needed mechanisms of independent function and
replication. Structural similarity among cells is the basis of tissue
formation and reproduction of organisms, whereas heterogeneity
among similar cells is critical for organism functioning. Since its
observation by Robert Hooke [1], the cell has become an
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important target of scientific analysis. Improvements in the sensi-
tivity of mass spectrometry (MS) now enable single cell and subcel-
lular analysis, allowing us to obtain unique multiplexed chemical
information on the presence of inorganic compounds, metabolites,
lipids, peptides, proteins, oligonucleotides, and polynucleotides in
single cells. A variety of MS approaches have been adapted to single
cell analysis, with secondary ionization mass spectrometry (SIMS),
electrospray ionization (ESI)-MS, and matrix-assisted laser desorp-
tion/ionization (MALDI) MS being most frequently used. Each of
these approaches has advantages and disadvantages, including spe-
cific requirements for sample handling and analyte extraction.

The goals of bioanalytical single cell MS are often the detection
and structural and quantitative characterization of endogenous and
exogenous compounds. The multiplexed nature of MS analysis
permits coverage of a wide range of analyte classes, making the
detection and characterization of important components of the
metallome, metabolome, lipidome, peptidome, and proteome of
a cell possible [2, 3]. Due to normal and pathological variabilities
and heterogeneities of biological systems, often exacerbated by
sample handling during preparation, experimental success depends
on the analysis of a representative number of samples (replicates) to
provide sufficient statistical power. As even a small sample can
contain hundreds of thousands to millions of cells, such MS mea-
surements may consume unrealistic resources and time. Therefore,
optimization of data collection leads to more efficient measure-
ments, enhanced results, and reduced data size. Though one can
reduce the amount of data obtained and enhance analyses using
several post-acquisition approaches, here we present a protocol that
improves data acquisition time and efficiency during the sample
preparation and optical imaging stages to facilitate high-through-
put single cell MALDI MS analysis. An important component of
this approach is the ability to filter individual cells with predeter-
mined morphometric and biochemical characteristics and only
select specific cells for follow-up MS analysis, excluding empty
spaces and structures, such as debris and dust. We have optimized
this protocol for the analysis of low-density populations of individ-
ual cells dispersed across a glass slide, which is a common practice in
biomedical investigations and clinical applications.

1.1 Comparison with

Other Approaches

Image analysis approaches have widespread application in a variety
of sample characterization processes, including single cell recogni-
tion, characterization, and identification [4–7]. More broadly, opti-
cal information for object location and sorting is widely used in
diverse applications, from fluorescent cell sorting [8, 9] to indus-
trial applications of computer vision systems [10], manufacturing
quality controls [11, 12], biomedical fields [13, 14], and big data-
related analyses [15].
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For spatial information-guided MS of single cells, two
approaches are typically used: (1) operator-defined targeting of a
region of interest within the sample and (2) analysis of samples
deposited at predefined coordinates. The first approach is widely
used in mass spectrometry imaging (MSI) where measurements are
typically performed on manually selected areas having the desired
morphological features, such as defined brain regions on brain
slices. Measurement of systematically deposited single cells (e.g.,
into array patterns), including individual bacteria, has been effective
with MS-based approaches, e.g., microarrays for mass spectrometry
(MAMS) [16–18], cell sorting with surface deposition [19], and
cell culture MS analysis [20, 21]. These cell targeting approaches
have multiple benefits, including high methodological control in
the sample localization process; however, they have some limita-
tions. For example, MAMS requires specifically designed and man-
ufactured wells (tailored to the size of the cells) that may complicate
work with cellular populations of different cell sizes, such as popu-
lations of isolated hippocampal neurons having more than 100-μm-
long terminals. For MSI, information is acquired on all spots in a
sample, some of which are empty spaces, nonbiological structures,
and cells. As result, a lower measurement throughput is achieved
and larger data files are created. Moreover, because cellular debris
will also be measured, the data set will require greater post-
processing effort.

Also interesting are the flow-based MS approaches, which can
quickly analyze hundreds to tens of thousands of individual cells
delivered to the mass spectrometer in a continuous flow of solution.
For example, mass cytometry utilizes fast, orderly delivery of cells
and sampling of their chemical composition using an inductively
coupled argon plasma (ICP) [22]. Moving away from MS, several
spectroscopic methods may provide multiplexed chemical informa-
tion from single cell populations including direct measurements by
Raman Fourier transform (FT) spectroscopy [23], infrared spec-
troscopy [24], and affinity probe-based methods, such as sequential
multiplex staining of cells and tissues [25, 26] targeting multiple
analyte classes that is dependent on probe specificity.

1.2 Development of

the Approach

Several decades of work [27–29] on the development and applica-
tion of single cell MALDIMS have demonstrated its ability to aid in
the discovery of new neuropeptides in selected cells. While the
approach is effective when specific cells need to be assayed,
throughput has been a major bottleneck, limiting MALDI MS
analysis to small numbers of individual cells. To address this issue,
we increased throughput by placing low-density scattered cells on a
slide, locating their positions, and then using these positions to
guide the laser (or ion beam for SIMS) [30–32]. Because this
process was somewhat tedious, in 2017 our group developed the
software package microMS [33] to automate cell finding and
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improve coordinate registration via a user-friendly GUI interface,
and using point-based image registration to correlate fiducial mar-
kers on the microscopy image to physical coordinates on the mass
spectrometer’s stage. The targeted profiling steps enabled by the
microMS-guided workflow include the ability to (1) determine
locations/coordinates of cells or other structures dispersed across
a microscope slide using an optical image; (2) select coordinates of
subpopulations of detected features (e.g., cells) according to flexi-
ble, user-defined criteria, such as shape and intercellular distances;
and (3) convert the cell pixel coordinates to physical stage coordi-
nates for the measurement platform (i.e., mass spectrometer) being
used. Importantly, the positional information can be combined
with other analyses, such as post-MALDIMS selected cell sampling
and capillary electrophoresis (CE)-MS analysis [34]. While devel-
oped for single cell analysis, with modifications the underlying
microMS code is versatile and can be applied to a variety of samples,
imaging modalities, and chemical analysis techniques. For more
advanced users, the addition of new, off-line instrument platforms
and even direct instrument control is possible. We describe the
most common usage of microMS, detail additional features, and
provide a starting point for its application to a range of other
platforms. Preparing the biological samples and performing the
MS measurements require a medium level of expertise. Our experi-
ence with training undergraduate research assistants has shown us
that novice users are capable of producing repeatable results after
2–3 months of practice, and this is the audience aimed for here. A
higher level of expertise or additional expert advice may be needed
for tissues that are hard to dissociate or when using complex or
unusual MS equipment.

1.3 Overview of the

Approach

The combination of single cell isolation, single cell MS, optical
imaging, optical image processing utilities, and molecular probes
provides opportunities for cell chemical typing and determination
of the chemical stability and heterogeneity of cell types in larger
cellular populations. Though such combinedmeasurements are not
common, the key mass spectrometric and optical imaging hardware
and software already exist, enabling us to link these approaches
together using the integrative microMS software package.

The major methodological steps in this multistage protocol are
(1) biological sample preparation, to include dissociation of indi-
vidual cells via enzymatic and/or mechanical treatments, labeling
with fluorescent dye, and deposition of cells onto an ITO-coated
glass slide and stabilized with glycerol, followed by partial or com-
plete glycerol removal using washing buffers; (2) acquisition of an
optical image of cells under fluorescent and transmitted light;
(3) processing of the acquired image with microMS to determine
cell location coordinates according to user-defined criteria; (4) sam-
ple preparation for MALDI MS analysis consisting of analyte
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standard deposition and MALDI matrix application (after this
stage, samples can be stored at low temperatures in a desiccator or
in a low oxygen environment but should be acclimated to ambient
temperature before MS analysis); (5) loading of the sample into a
mass spectrometer and performing point-based image registration
by locating fiducial markers in microMS and the same location on
the MS stage; (6) loading coordinates of the targeted cells into the
mass spectrometer’s software; (7) acquisition of mass spectra;
(8) and finally, data processing and analyses using a variety of
computational tools available from different industrial and aca-
demic sources. The main goals of the analyses are the measurement
of the chemistry within the cell, thus enabling chemical heteroge-
neity of cellular populations to be probed, and the biomarkers for
cell types to be determined.

Using this approach, several hundred to a thousand cells per
slide are commonly measured. Depending on the instrument used
and settings selected, each slide can be analyzed in less than 1 hour,
allowing at least eight slides to be processed per day. There are
several options for further increasing the number of analyzed slides,
including automation of sample loading/unloading as well as gen-
eration of scripts for automatic import of cell coordinates and
instrument training (e.g., mass spectrometer) using preset fiducial
marks, and available hardware and software. However, additional
efforts should be made toward registration of fiducial marks after
sample loading into a mass spectrometer. This step currently
requires involvement of an operator and thus, limits measurements
to operator availability.

1.4 Advantages and

Disadvantages of the

Approach

Analysis of intact cells provides distinct advantages in comparison
with MS measurements of thin tissue sections. In most cases, tissue
section samples analyzed with MS do not provide information on
the chemical profile of individual cells. This may be because cells are
cross-sectioned and only parts of cells are analyzed, or interference
from other surrounding cells is causing difficulties in assessing cell
content. In addition, even when the probe size is on the order of
(or smaller than) a cell, cells are irregularly shaped and the probes
are often not well-aligned with cells, so that one is not assured of
sampling from an individual cell when assaying tissue sections.

In contrast, dispersing individual cells at distances typically
exceeding the probe (laser) diameter ensures that different cells
are not examined simultaneously. In addition, one can use wetter
conditions for analyte extraction and incorporation into MALDI
matrix crystals so that limited spreading of the analytes to adjacent
sections is not an issue. Because of these factors, single cell MALDI
MS increases data reliability by reducing single cell sample cross-
contamination and decreases the likelihood that noncellular struc-
tures or multicellular aggregates are assayed. The microMS-based
workflow can be adapted to a large variety of sample plates besides
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the standard microscopy glass slide. Fluorescent images can also be
taken from nontransparent, 386-well polished MALDI sample
plates and custom-designed glass or silicon sample plates
[35]. Optical image-guided MS analysis can be adapted to other
imaging modalities, including electron microscopy, and magnetic
resonance, x-ray, and ultrasound imaging. As a last benefit of
MALDI MS, after a measurement, much of the sample is left,
allowing the remaining material to be characterized again. We
already have demonstrated that several technologies can be com-
bined with microMS-based analysis for single cell measurements,
including CE-MS [34] and immunolabeling [36], and it is likely
that others will follow.

As with many other technologies for measuring single cells,
there are some limitations to the described approach, but there are
also viable solutions to overcoming some of these challenges.
microMS-based single cell MS analysis does not preserve informa-
tion on intra-specimen localization of individual cells within a
sampled tissue. To correlate single cell and tissue level data sets
with cell type/state, biomarkers can be used in follow-up measure-
ments of the same tissue utilizing MSI or immunohistochemistry,
thereby addressing this issue. Another concern is that bias can be
introduced when isolating cells because of differences in their
mechanical stability or susceptibility to damage during dissociation.
If one cell type is damaged and another is not, this would be
difficult to determine based solely on the MS data. Moreover,
different enzymatic treatments may be needed for isolation of
astrocytes and neurons, or cells may not be stained uniformly
with a specific dye. For example, we have noticed that Hoechst
33342 produces dim staining in cerebellar Purkinje neurons com-
pared to granular cells. As a remedy, the addition of dyes for
monitoring cell pyroptosis, apoptosis, or cell lysis [37], followed
by optical imaging and exclusion of specific cells during MS analy-
sis, can be introduced.

Despite the multiplexed nature of single cell MALDI MS anal-
ysis, analyte coverage is relatively low, typically with 10–200 com-
pounds detected. This issue is due in part to low analyte amounts
and also because of the relatively low dynamic range and resolving
power of direct MS compared to hyphenated approaches such as
CE-MS and liquid chromatography (LC)-MS. However, the intro-
duction of ion mobility to the front end should address this draw-
back, and use of ultrahigh-resolution FTMS should also increase
the number of analytes detected and characterized.

Despite the limitations noted above, microMS-based single cell
MS is a flexible and versatile platform for analyses of cellular
agglomerates and single cells that we have successfully applied to
the characterization of cellular populations of individual islets of
Langerhans, dorsal root ganglia, and brain regions [32, 36,
38]. Low analyte consumption techniques, such as SIMS and
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MALDI MS, are hyphenated for analysis of the same cellular popu-
lation and provide wider analyte coverage and additional opportu-
nities for cell phenotyping [38]. Low analyte consumption as well
as characteristic sample preparation for MALDI MS, where not all
analytes are extracted and incorporated into MALDI matrix crys-
tals, allows post-MALDI MS detection of cellular proteins using
immunolabeling [36] and metabolites by CE hyphenated to
ESI-MS [34]. microMS is critical for determining cell targets for
more time-consuming analytical measurements such as CE
ESI-MS. Typically, a single CE ESI-MS run takes 10–30 min;
therefore, only a small number of cells can be analyzed. MALDI
MS provides information on cell content and cell types to guide
selection of single cells for a follow-up analysis by CE-MS.
microMS processing of coordinates of cellular locations enables
different approaches for cell content collection, including micro-
junction approaches as well as other analytical platforms [34].

While more standard applications of the approach are covered
here, microMS can be tailored to new and diverse instruments and
also offers more advanced operations, including direct instrument
control. For example, many other types of single cell analysis can be
hyphenated with microMS, e.g., vibrational spectroscopies such as
infrared, near infrared, and Raman. Knowledge of cell coordinates
allows formation of multiplatform data sets for extensive character-
ization of individual cells and cellular populations. Single organelle
analysis is a new area for microMS-based MS [39]; however, this
application is not covered in the current protocol.

1.5 Experimental

Design Considerations

It is important to ensure that all components of the experimental
design are compatible and sufficiently flexible for achieving the
planned goals. For example, not all instrumental software packages
are capable of generating optical image files that are compatible
with microMS. Also, some cell labeling methods may not be equally
efficient for specific cell types. Depending on the biological model,
targeted analyte class, and study goals, different approaches have to
be chosen for different stages of the experimental process, begin-
ning with suitable cell isolation, labeling and storage techniques,
selection of the MALDI matrix, and microscopy and MS instru-
mentation, and finally, choosing appropriate data analysis tools,
methods, and resources.

Especially important is the quality of the cell isolation and
sample preparation process to ensure accurate representation of
the cell population. All components should be tested at the prelim-
inary stage of planning. Before the actual experiment is started,
multiple optimizations should be implemented and evaluated for
the analytes of interest, e.g., dispersing cells at an appropriate cell
density, optimizing the MALDI matrix solution and its application,
and adjusting the MALDI MS parameters. All solutions and sur-
faces used should be tested for the presence of detectable, or not
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detectable but interfering, analytes and compounds. For example,
polymers such as polyethylene glycol and polysiloxane are often
used in molecular biology but cannot be used for this protocol.
Therefore, control experiments utilizing analyte standards and
well-characterized biological models should be performed.

In cases of long-term studies where samples become available
over an extended time, the timing and order of their analysis should
be considered. MS of biological samples is prone to batch effects;
therefore, accumulation of samples and their appropriate storage
must be validated in a relatively short period of time prior to
analysis. To further reduce the influence of batch effects, deposition
of cell populations collected from different donors on different
marked areas of the same glass slide in random order is suggested.

2 Materials

2.1 Biological

Materials

When developing this protocol, we used cells from the rat
and human islets of Langerhans as models. Isolated human islets
were provided by our collaborators at the University of Pennsylva-
nia, with the sample collection and processing approved by the
University of Pennsylvania Institutional Review Board (protocol
number: 832134). Written consent was obtained from responsible
parties (tissue donors or relatives of donors). The handling of
human cell samples was performed in accordance with Biosafety
Level 2 regulations described for the project and approved by the
relevant Institutional Biosafety Committees. Adult Sprague-
Dawley rats were purchased from ENVIGO (https://www.envigo.
com/model/hsd-sprague-dawley-sd). Protocols for animal care
and procedures were approved by an Institutional Animal Care
and Use Committee and be in full compliance with local, federal,
and some international guidelines for the humane care and treat-
ment of animals.

2.2 Reagents 1. 2,5-Dihydrobenzoic acid (DHB) (MilliporeSigma, cat.
no. A3539).

2. 4-(2-Hydroxyethyl)piperazine-1-ethanesulfonic acid (HEPES)
(MilliporeSigma, cat. no. H3375).

3. Acetonitrile (ACN) (Thermo Fisher Scientific, cat. no. A998-
4).

!CAUTION ACN is toxic. When handling, wear gloves
and use a pipetting aid.

4. Calcium chloride (MilliporeSigma, cat. no. C7902).

5. Glycerol (MilliporeSigma, cat. no. G7893).

6. Magnesium chloride hexahydrate (MilliporeSigma, cat.
no. M2393).
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7. Magnesium sulfate heptahydrate (MilliporeSigma, cat.
no. M2773).

8. Peptide calibration standard II (angiotensin II, angiotensin I,
substance P, bombesin, ACTH clip 1–17, ACTH clip 18–39,
somatostatin 28, bradykinin fragment 1–7, renin substrate tet-
radecapeptide porcine) (Bruker Corp., part no. 222570).

9. Potassium chloride (MilliporeSigma, cat. no. P5405).

10. Potassium phosphate monobasic (MilliporeSigma, cat.
no. P5655).

11. Sodium bicarbonate (MilliporeSigma, cat. no. S5761).

12. Sodium chloride (MilliporeSigma, cat. no. S5886).

13. Sodium phosphate (Thermo Fisher Scientific, cat.
no. S374–500).

14. Nuclear dye Hoechst 33342 (Thermo Fisher Scientific, cat.
no. 62249).

15. Trifluoroacetic acid (TFA) (MilliporeSigma, cat. no. T6508).
!CAUTIONTFA is highly corrosive. When handling, wear

gloves and goggles, use a pipetting aid, and operate in a venti-
lated chemical hood.

16. Trypsin LE (Thermo Fisher Scientific, cat. no. 12604013).

17. Paraformaldehyde (Fisher Scientific, cat. no. 50-980-487).

18. Tris-EDTA buffer solution (Sigma-Aldrich, cat. no. 93283).

19. N-Acetyl-L-cysteine NAC (Sigma-Aldrich, cat. no. A7250).

20. Collagenase P from Clostridium histolyticum (Sigma-Aldrich,
cat. no. 11213857001).

2.3 Laboratory

Equipment

1. Diamond scriber (e.g., Electron Microscopy Sciences, cat.
no. 62107-ST).

2. Microtubes, 1.5 mL (e.g., Eppendorf Safe-Lock Tubes, cat.
no. 022363204).

3. 15 ml screw-cap tubes (Falcon, cat. no. 352095).

4. 50 ml screw-cap tubes (Falcon, cat. no. 352070).

5. Disposable borosilicate glass Pasteur pipets (Fisher Scientific,
cat no. 13–678-20A).

6. Non-treated culture dishes D � H 60 mm � 15 mm (e.g.,
Corning, cat. no. CLS430589).

7. Disposable safety gloves (e.g., Microflex® 93–833, XCEED®
nitrile gloves, powder-free (MilliporeSigma, cat.
no. Z687448)).

8. Disposable graduated transfer pipets (e.g., Fisher Scientific, cat.
no.13–711-9 AM).
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9. Safety glasses (e.g., MR0111IDMirage safety glasses (Radians,
cat. no. MR0111ID).

10. Face masks (e.g., disposable PPE Latex-Free 3-Ply Face Masks,
ProPac, SKU: D8012).

11. Paper absorbent wipes (e.g., Kimwipes, Kimberly-Clark Inc.,
cat. no. 34155).

12. Indium tin oxide (ITO)-coated microscopy glass slides (coat-
ing resistance, 70–100 ohms; dimensions, 25 � 75 � 0.8 mm)
(e.g., Delta Technologies, cat. No. CG-90IN-S110).

13. Automated matrix spraying system (e.g., HTX M5 Sprayer;
HTX Technologies).

14. Water bath for 34–37 �C incubations (Cole-Parmer Polystat
EW-20873-45).

15. Digital multimeter – ohmmeter (e.g., HHM10-20-30-DMM-
Series, www.omega.com).

16. Plastic rectangle microscope glass holders (boxes for five
slides).

17. Ultra-microbalance (e.g., Cubis II, Sartorius).

18. Vacuum-sublimation apparatus (e.g., Ace complete apparatus,
H � I.D. 250 mm � 152 mm, Sigma-Aldrich, cat.
no. Z258717).

!CAUTIONWorking with glass vessels kept under vacuum
requires establishing and following specific standard operating
procedure(s).

19. A Styrofoam box to hold ice

20. pH meter (e.g., FiveEasy Plus pH meter FP20-Micro-Kit,
Mettler Toledo, material no. 30266940).

21. Surgical tools, including forceps, scissors, and a vessel clamp
(e.g., Fine Science Tools, cat. no. 18320-11).

22. 5 mL plastic syringe with blunt end 20G–30G needle attached.
Needle size depends on animal size, to correspond to the
diameter of the bile duct, and should be determined experi-
mentally. For easier operation, a fine Teflon or other plastic
tubing can be attached to end of needle extending working
distance and reducing effect of syringe motion on success of
solution injection.

23. Guillotine for rodents (e.g., Nemi Guillotine, Braintree Scien-
tific, cat. no. NS-80 2).

24. Interchangeable magnifier headset with LED used during sur-
gical procedures (e.g., Fine Science Tools, cat. no. 28080-10).

25. Flexible plastic tubing (e.g., Tygon one WHATMAN Inline
Filter Device, 60 psi (https://www.grainger.com/, item
no. 32HK77)).
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26. Two 50 mL heavy wall glass filtering flasks (e.g., https://www.
usplastic.com/, item no. 76984).

2.4 Mass

Spectrometry

Instruments and

Software

1. MALDI-TOF/TOF mass spectrometer (we use an ultrafleX-
treme, Bruker Corp.)

2. Fourier transform ion cyclotron resonance (FTICR) mass spec-
trometer (we use a 7 T solariX, Bruker Corp.).

3. flexAnalysis software (Bruker Corp.).

4. flexControl software (Bruker Corp.).

5. flexImaging software (Bruker Corp.).

2.5 microMS

Software and

Hardware

1. The microMS software downloads (http://neuroproteomics.
scs.illinois.edu/microMS.htm) are comprised of a compiled
Windows executable, “microMS.exe” (ZIP folder), which
includes a Python interpreter and all dependencies, and the
Python Source Code, “microMS” (ZIP folder). The microMS
User Guide can also be downloaded from this site. The opera-
tion and use of this code have been described in https://
github.com/troycomi/microMS and [33].

2. Python (https://www.python.org/downloads/).

3. PyQt5 (https://www.riverbankcomputing.com/software/
pyqt/download5).

4. NumPy (http://www.numpy.org/).

5. SciPy (https://www.scipy.org/).

6. Matplotlib (http://matplotlib.org/).

7. Skimage (http://scikit-image.org/docs/dev/api/skimage.
html).

8. OpenSlide (http://openslide.org/) and OpenSlide Python
( h t t p s : // g i t h u b . c o m / o p e n s l i d e / o p e n s l i d e -
python#installation).

9. PySerial (https://pypi.python.org/pypi/pyserial).

10. The software requires a workstation running an up-to-date
Windows operating system (e.g., Windows 10, 32 GB of
RAM, a 1 TB hard drive), or Linux distributions (e.g., Fedora,
Ubuntu).

2.6 Biochemical and

Mass Spectrometry

Databases

1. Lipids Maps Structure Database (http://www.lipidmaps.org/
data/structure/).

2. UniProt (https://www.uniprot.org) [39].

3. Human Metabolome Database (https://hmdb.ca).

4. MassBank of North America (MoNA) (https://mona.fiehnlab.
ucdavis.edu/).
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5. METLIN – Scripps Research (https://metlin.scripps.edu).

6. Protein – NCBI (https://www.ncbi.nlm.nih.gov/protein).

2.7 Microscopy

Equipment

1. High-performance dissection stereomicroscope (e.g., Leica
MZ 7.5 with 7.9:1 zoom; Leica Microsystems Inc.).

2. Transmission light microscopy inverted microscope equipped
(e.g., Axiovert 25 with AxioCam MRc camera; ZEISS
Microscopy).

3. UV fluorescence microscopy upright microscope (e.g., Zeiss
Axio Imager.M2 (https://www.micro-shop.zeiss.com/en/se/
s y s t em/ax io+ image r+2 - ax io+ image r.m2-up r i gh t
+microscopes/10215/#variants) equipped with an Axiocam
503 mono; ZEISS Microscopy, cat. no. 4109664265591000).

4. Color microscope camera (e.g., AxioCam ICc 5; ZEISS
Microscopy, cat. no. 4265540000000000).

5. Fluorescence illumination system (e.g., X-Cite 120Q Iris FL
Light Source; Lumen Dynamics).

6. Illuminator (e.g., VIS-LED; ZEISS Microscopy, cat.
no. 4230539030000000).

7. Filter set (e.g., FL Filter Set 49 DAPI, EX G365 S free; ZEISS
Microscopy, cat. no. 4880499901000000).

8. UV transmitting objective (e.g., Plan-Apochromat 10�/0.45
WD ¼ 2.0 M27; ZEISS Microscopy, cat.
no. 4206409900000000, or EC Plan-Neofluar 5�/
0.16 M27; ZEISS Microscopy, cat. no. 420330-9901-000).

9. Scanning stage (e.g., 130 � 85 piezo STEP (D); ZEISS
Microscopy, cat. no. 4320229902000000).

10. An image acquisition and processing package (e.g., ZEN soft-
ware ver. 3.1 (blue edition); ZEISS Microscopy).

11. An image processing package (e.g., Fiji, https://imagej.net/
Fiji).

12. Microsoft Office package for data visualization and .txt file
editing (https://www.microsoft.com/en-us/microsoft-365).

3 Methods

3.1 Reagent

Preparation

1. Modified Gey’s balanced salt solution (mGBSS) containing
(in mM) 1.5 CaCl2, 4.9 KCl, 0.2 KH2PO4, 11 MgCl2, 0.3
MgSO4, 138 NaCl, 27.7 NaHCO3, 0.8 Na2HPO4,
25 HEPES and 10 glucose, pH 7.2.

2. Glycerol stabilization solution containing 33% (vol/vol) glyc-
erol mixed with 67% mGBSS.
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3. MALDI matrix solution containing DHB saturated in a 1:1
mixture of ACN: 0.1% (vol/vol) aqueous/TFA acid. Many
additional MALDI matrices are available for investigation of
small metabolites, peptides, proteins, nucleotides, and polysac-
charides, and can be used in biochemical profiling of single
cells.

3.2 MALDI Mass

Spectrometry

Calibration

Mass spectrometers should be tuned and calibrated before running
high-throughput single cell analysis. Calibration of mass spectro-
meters, preferably, should be performed for each sample (e.g., ITO
glass slide).

1. Time-of-flight (TOF)-TOF instruments: standards are placed
on the same surface where samples are deposited. Even slight
difference in distance between sample surface and mass spec-
trometer detector leads to variable measurements.

2. FTICR instruments (e.g., Bruker solariX): can be calibrated
with secondary ESI ion source providing better options for
calibration than MALDI ion source. Calibrants should cover
the entire m/z range under analysis. Typically, for detection in
positive mode, ion signals of peptide standards (m/z
700–6000) and ion signals of MALDI matrix (m/z 100–600)
are used for instrument calibration.

3. Ion trap instruments (including FT mass spectrometers
equipped with ESI and MALDI ion sources): can be calibrated
via ESI source using commercially available ESI tuning mixes,
or volatile salts of metals (such as sodium or lithium format).

3.3 Solutions for

Human Pancreatic

Islet Dissociation and

Cell Labeling

Fresh trypsin LE islet dissociation media should be prepared as
follows:

1. Prepare DPBS Tris-EDTA buffer: according to manufacturer’s
instructions, dilute 10� DPBS (no calcium, no magnesium)
stock with Tris-EDTA buffer solution according to manufac-
turer’s instructions, containing 10 mM Tris-HCl, 1 mM dis-
odium EDTA, pH 8.0.

2. Prepare 10mM stock solution of N-acetyl-L-cysteine (NAC) in
1� DPBS. N-Acetyl-L-cysteine is a cytoprotective agent
against reactive oxygen species.

3. Add NAC into 1� DPBS Tris-EDTA buffer (1:100).

4. Dilute (1:1000) Hoechst 33342 of commercial stock (1 mg/
mL) with 1� DPBS Tris-EDTA buffer NAC solution.

5. Dilute (1:10) 10� trypsin LE media with 1� DPBS Tris-
EDTA buffer NAC solution. Antibiotics can be added to this
solution as well to prevent bacterial growth during incubations.
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3.4 Solutions for Rat

Pancreatic Islet

Dissociation and Cell

Labeling

1. One hour before the procedure is started, prepare 10 mL (per
rat) of 1.4 mg mL�1 collagenase P solution dissolved in
mGBSS. 5 mM d-glucose and 0.05%–1% (w/v) bovine serum
albumin (BSA) can be added to collagenase P solution [40].

2. Prepare 5 mL (per rat) of the glycerol stabilization solution.

3. Dilute (1:1000) Hoechst 33342 commercial stock (1 mg/mL)
with the glycerol stabilization solution. Keep solution at 15 �C.

3.5 Solution

Preparation

1. Ammonium acetate sample rinsing media used after cell stabili-
zation with glycerol: dissolve 150 mM ammonium acetate
(NH4Ac) in water [41].

2. Bovine serum albumin (BSA) solution used to coat surfaces
coming in touch with cells during sample preparation: dissolve
1% bovine serum in milliQ water. Can be prepared and stored
at 4 �C for 1–2 weeks.

3.6 ITO Glass Slide

Preparation

1. Timing 2–5 min per slide.

2. Use multimeter to check the conductivity of the ITO glass
surface to verify the choice of glass side and orientation of
conductive surface, which is not obvious due to transparency.
Note that the use of conductive glass slides is critical for analysis
with TOF mass analyzers. Measurements via ion trap mass
analyzers such as FTICR systems are less reliant on substrate
conductivity, which allows the use of conventional microscope
glass slides for sample deposition and ultimately lowers the
sample preparation cost.

3. Use a diamond scriber or laser etcher to etch 1–3-mm-wide
fiducial marks (can be crosses or digits), important sample
information, and markups for positioning of standards and
MALDI matrix blanks on conductive side of the slide. It is
important to place markups on the same surface as the samples
and take care in not damaging conductive surface in a way (e.g.,
complete circles) that would cause some regions of the slide to
lose electric conductivity with other regions.

4. Wipe slides with Kimwipes, or use clean compressed nitrogen
gas stream, to remove glass dust and small shards resulting
from the markup process or from formation of stress cracks
on the slide during etching.

5. Store slides in properly marked containers, e.g., microscopy
glass storage boxes, protecting them from dust. Inscribed or
etched slides can be stored at ambient conditions indefinitely.

!CAUTION Ensuring the glass slide surface is free from
chemical contamination should be verified using a randomly
chosen slide from the manufacturer’s box before working on
sample preparation. Additional washing steps can be imple-
mented for removal of possible contamination.
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!CAUTION Wear gloves and work on a clean, dust-free
surface to avoid ITO slide contamination and fingerprints.

!CAUTION Scribing and etching leads to a decrease in
glass slide mechanical stability – handle finished slides
with care.

3.7 Optical

Microscopy

Optical microscopy is an important part of the described proce-
dure. Two different systems can be used – a microscope (either
inverted or upright) or histology/pathology slide scanners. These
instruments should be spatially and optically calibrated/tested.
Evaluation of a control/reference sample using a stage micrometer
(e.g., Thorlabs part no. R1L3S1P) and fluorescent microscope
slides (FSK1–FSK6) is critical for reliable and reproducible mea-
surements. Finally, the entire workflow should be tested and opti-
mized before starting the experiment. Here is a brief description of
an Axio Imager.M2 microscope setup established using the ZEN
software.

1. Turn fluorescent and transmission light sources ON.

2. Set 100% light after filter cube is going to camera.

3. Select None or DIC filter for brightfield imaging, and DAPI
filter for fluorescence imaging.

4. Program sequential acquisitions of brightfield and fluorescence
images.

5. Find optimal illumination for both channels.

6. Update method, saving experimentally determined settings.

7. Set acquisition of Tiled images using mosaic mode. The num-
ber of tiles, their positions, and overlap are determined at this
step using the Advanced Setup option.

8. Due to the typically wide areas of samples analyzed, semiauto-
matic adjustment of focus should be done along the slide.
Therefore, establish a set of reference points across the entire
sample where the optical focus is automatically adjusted. Typi-
cally, we use 9–12 evenly distributed Focus Surface areas for
automatic Z-position adjustment. It is important to determine
which channel – brightfield or fluorescent – provides better
options for surface focusing. Depending on the objective,
magnification, and specimen, different outcomes can be
achieved.

9. Under visual control, adjust and save Z-positions at each refer-
ence point.

10. Due to the large size of resulting image files (2–8 GB per tiled
image), preplan and establish your image storage, processing,
and export pipeline. Creating an easy-to-navigate directory
structure and file naming system will save time by limiting the
number of times images should be loaded for evaluation.
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11. Incorporate tile stitching into the pipeline to reduce file sizes
and increase the precision of cell coordinate finding.

12. Correct image brightness, contrast, and in some cases, color.
This correction preferably should be done before image export
into the microMS-compatible bigTIFF format. For example,
due to differences in brightness of stained nuclei, increase the
brightness and contrast for the fluorescent channel to levels
that allow capture of the maximal number of cells, which is
critical despite potential loss or distortion of morphological
information. Finding of all cell coordinates is a paramount
goal of this procedure. Missing low-intensity stained cells will
lead to their exclusion from the distance filtering process and
possible signal acquisition from more than single cell.

13. Save the method for saving tiled, stitched, and optimized
images into the bigTIFF format.

14. Test method performance using small-size images.
!CAUTION Resulting images should have minimal distor-

tions in background to avoid formation of artifacts during
image acquisition. The addition of a shading correction step
at this point is important for tiled images to reduce the influ-
ence of optical path artifacts onto the final image, which may
interfere with determination of localization of targeted struc-
tures or introduce faux structures.

3.8 Optical and Mass

Spectrometric Quality

Control of

Experimental

Solutions and Supplies

1. Use 20� objective and inverted microscope in fluorescent and
transmission light modes to check for the presence of particles,
including microbes and fungi, in solutions and on experimental
surfaces. Dust particles may produce fluorescent signals similar
to those from biological structures. Microorganism-related
compounds can be detected by MS and assigned as being
from sample cells.

2. If particulate matter is found in solutions, reagents, and/or
supplies, filter or replace them and incorporate additional
cleanup steps to ensure working surfaces remain dust- and
contaminant-free (wet wiping, blowing with pressurized gas).

3. Run quality control experiments with all supplies and solutions
for sample preparation as well as analyze reagents relevant to
MS measurements. Create a library of signals detected. Con-
taminants, such as polyethylene glycols, are present in many
scientific materials and reagents, and should be controlled for.

3.9 MALDI Matrix

Application

MALDI matrix should be applied using optimal conditions for
analyte extraction from the sample and mixing of analytes with
MALDI matrix at the most effective ratio for the analyte class
under investigation [42]. An excess or deficit of matrix can lead to
poor analyte ionization, lower sensitivity of detection, and/or high
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noise in the spectra. Matrix type, solvent composition, duration of
contact between the MALDI matrix solution and sample, and rate
of matrix drying affect matrix crystal formation, which in turn
influences signal quality during measurements. The choice of
MALDI matrix, as well as its solvents and additives, is critical for
detection of a particular class of analytes. For recommendations,
search the literature (e.g., a search of https://www.sigmaaldrich.
com for “MALDI matrix” produced 112 entries) or instrument
vendor guidelines. There are several methods for applying MALDI
matrix.

1. Aerospray option 1: manual wet application using an airbrush.
Multiple parameters can be adjusted for deposition of MALDI
matrix onto a sample using an airbrush, including distance
between airbrush nozzle and sample, spraying time, concentra-
tion of MALDImatrix, ratio of organic and aqueous solvents in
this mixture, nebulizing gas flow rate, as well as physicochemi-
cal properties of solvents, e.g., volatility. Additionally, the air-
brush needle/nozzle size plays a critical role in the formation of
droplets of different dimensions and, respectively, different
drying times. Artistic airbrushes with 0.1–0.2 mm diameter
needle sizes produce the finest mist for application of MALDI
matrix solution; 0.3–0.35 mm needles generate predominantly
medium-sized droplets. Airbrushes with 0.4–0.5 mm needles
are good for quicker application of large volumes of matrix
solution.

2. Aerospray option 2: automated wet application using a com-
mercial device. The HTX-M5 sprayer is an advantageous tool
for uniform application of MALDImatrix solution onto several
ITO glass slides. As an example, effective matrix deposition can
be achieved with 30 mg/ml DHB in 1:1 (v:v) methanol/0.01%
TFA in water applied in two passes from a nozzle positioned at
a distance of 6 cm from the sample, with a nozzle velocity of
1300 mm/min, temperature of 70 �C, MALDI matrix flow
rate of 100 uL/min, and matrix track spacing of 2.5 mm.

3. Sublimation (dry application): One of the best approaches for
dry, thin, and relatively uniform MALDI matrix application is
via sublimation [43]. This approach has demonstrated excel-
lent performance in lipid andmetabolite analysis where analytes
are located on sample surfaces, e.g., on a cellular cytoplasmic
membrane. However, intracellular compounds are best
extracted from cells by organic solvents and internalized within
the MALDI matrix crystals. The matrix sublimation/recrystal-
lization approach was developed to enhance detectability of
larger molecules, such as peptides and proteins in an m/z
range of 1000–18,000 [44]. To determine the deposited
matrix amount and surface density of the MALDI matrix,
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ITO glass slides are weighed on a micro- or ultra-microbalance
before and after the sublimation process. For sublimation,
200–500 mg of MALDI matrix is evenly distributed on alumi-
num foil placed at the bottom of the sublimation chamber; an
ITO glass slide with mounted samples is affixed to a cold finger
using double-sided copper tape. The assembled apparatus is
placed in a heating mantle, medium vacuum (~10 mTorr) is
developed inside, the cold finger is filled with iced water
(~4 �C), and the entire system is acclimated for 5 min. The
mantle is then heated 5–10 min to achieve the targeted thick-
ness of MALDI matrix coating. Sublimation is stopped by
removal of the heat source and slow venting of the apparatus,
its disassembly, and sample removal.

4. MALDI matrix application approaches can be compared [45]
and parameters should be optimized, depending on the results
of preliminary measurements involving several differently trea-
ted samples.

!CAUTION MALDI matrix application steps should be
performed in a well-ventilated space, such as a chemical hood,
to avoid inhalation of MALDI matrix and solvent vapors and
aerosols, which may have hazardous properties.

3.10 Vacuum-

Assisted Liquid

Aspiration Setup

1. Liquid aspiration system built in accordance with Biosafety
Level 2 regulations [46].

2. The system is connected in a chain using appropriate diameter
clear, flexible plastic tubing and two 50 mL heavy wall glass
filtering flasks.

3. One end of the chain is attached by the tubing to an in-house
vacuum system, followed by the filter, overflow flask with
punched rubber stopper with glass or plastic tube inserted,
aspiration flask with punched rubber stopper with glass or
plastic tube inserted, and ending with tubing of appropriate
length capped with a 200 μL universal plastic pipet tip.

4. Fill 10% of both flask volumes with disinfectant liquid, e.g.,
freshly prepared 10% bleach solution or different chaotropic
agents.

!CAUTION Filters should be replaced at least annually.
!CAUTION Disinfectant solution should be replaced after

each daily experimental session.
!CAUTION Depending on the appropriate biological

safety regulations, the entire system, except the filter, can be
autoclaved or exposed to disinfectant according to regulations
for the particular hazard and disinfection approach required.

3.11 Mass

Spectrometer Setup

1. Determine the laser footprint area and its position during
instrument training. The laser footprint position may shift
over time due to different events, including ion source cleaning
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on TOF-TOF instruments. Therefore, load an ITO glass slide
coated with a thin but visible layer of MALDI matrix.
Completely ablate several individual spots of MALDI matrix
layer with the laser.

2. Measure spot sizes and determine the morphological para-
meters of the laser’s footprint. Note the laser footprint position
in relation to the software-generated crosshair used in sample
navigation, visible on the computer monitor. If laser alignment
is not possible moving forward, the experimentally determined
laser position should be marked on the monitor and used in
instrument training.

3. Choose a method for biological data acquisition using the mass
spectrometer. Manufacturer-provided default methods can be
used as the starting point for sample- and analyte-specific
method development. High-throughput single cell MS analysis
utilizing microMS can be performed on majority of mass spec-
trometers equipped with sufficiently precise programmable
sample or microprobe positioning. For example, we utilized
two Bruker instruments [33, 38]: (1) an ultrafleXtreme mass
spectrometer, set at a m/z window of 400–3000. The “Ultra”
(~100 μm footprint) laser setting was used with 300 laser shots
at 1000 Hz to generate a MALDI-time-of-flight mass spec-
trum of each cell; (2) a 7 T solariX FTICR mass spectrometer,
operated with a m/z window of 150–3000; 300 scans were
collected with a 4-Mega Word time domain. Each mass spec-
trumwas acquired with 20 laser shots at 1000Hz and 60% laser
energy.

4. Using prespotted analyte standards, calibrate the mass
spectrometer.

5. Optimize the chosen method. The most useful customizations
include adjustment of the laser intensity, laser footprint size
and geometry, number of laser shots per acquisition, detector’s
gain (should be adjusted with care to ensure a longer detector
lifespan), m/z range, time of delay of ion extraction (for TOF
instruments), detection polarity, as well as ion optics voltages.
Preparation of high-density cell population samples for realistic
tuning of instrument parameters is optimal. Comparative anal-
ysis of the parameters of several default methods followed by
optimization of the best-performing one may produce faster
results.

!CAUTION To avoid mass spectrometer damage or a
reduction in operational longevity, most mass spectrometer
parameters should be adjusted only by specifically trained per-
sonnel or by the instrument vendor. Most MS instrument
vendors provide remote diagnostics and assistance, which is a
suitable for method optimization, if needed.
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3.12 microMS

Software Installation

and Execution

microMS can be installed on either Windows or Linux computers,
as follows:

3.12.1 Install microMS

on a Windows Computer

1. For the base components of microMS to run properly, the
following software dependencies should be downloaded and
installed, with links provided at http://neuroproteomics.scs.
illinois.edu/microMS.htm: PyQt5, NumPy, SciPy, Matplotlib,
Skimage, PySerial, OpenSlide, and OpenSlide Python. Most
dependencies of microMS are included in standard distribution
packages of Python 3. We have had success using anaconda,
which also includes an IDE (https://www.continuum.io/
downloads.) A Python 3.X (X > ¼ 5) version must also be
installed.

2. After download, PySerial and OpenSlide require separate
installations. PySerial is installed by opening Windows Power-
Shell and entering pip install pyserial. This should automatically
install the most recent version.

3. OpenSlide requires additional binaries, located at http://
openslide.org/download/ under Windows Binaries. Down-
load and extract the folders, placing them in your Documents
or Program files directories. The contained bin folder also must
be added to the operating system path (e.g., C:\Program Files
\OpenSlide\bin\; see http://www.howtogeek.com/118594/
how-to-edit-your-system-path-for-easy-command-line-
access/). Once added correctly, the OpenSlide Python wrapper
is simply installed by entering pip install openslide-python in
PowerShell.

4. With the dependencies installed, microMS is installed by down-
loading from http://neuroproteomics.scs.illinois.edu/
microMS.htm and extracting the ZIP file into a designated
directory (extracted size is ~560 MB). After downloading all
packages and unzipping the archive, no further installation of
microMS is required. The main script is run with Python
microMS.py in a command prompt in the script directory or
by double-clicking the microMS.bat file, which runs the above
command and waits for a key press.

5. To run the program, double click “microMS.exe”; two win-
dows will be opened (Fig. 1).

3.12.2 microMS

Installation and Execution

on Linux Computers

1. With an installation of Python 3, the required packages are
installed in the terminal with pip3 install <package>.

2. OpenSlide is installed with apt-get install python-openslide pip3
install openslide-python.

3. After unzipping the microMS file, the main method is run with
either Python microMS.py or ./microMS.py after executable
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permission is granted (i.e., chmod +x microMS.py). Adding
the microMS directory to the PATH variable will allow execu-
tion from any directory.

Fig. 1 BigTIFF images may be decimated to 8� and 64�, generating the file sets: “8�<image name>” and
“64� <image name>,” with <image name> being the name of original file (see Fig. 2). (a) Original bigTIFF
files with names ending with optical channel abbreviations c1–c3 stored in a single directory. (b) Activation of
bigTIFF decimation option for multichannel image processing. (c). bigTIFF decimation process visualized in
second microMS window. (d) Original bigTIFF and decimated files
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4 Procedures

4.1 Islet

Dissociation: Human

Single Cell Populations

Here we describe the steps required for single islet enzymatic
treatment, dissociation, and deposition of populations of individual
cells onto ITO glass slides.

1. Under stereomicroscope, manually collect 10–20 isolated
human islets located in transportation media.

2. Transfer islets into a BSA-treated Petri dish filled with 4 mL of
1� DPBS Tris-EDTA buffer NAC solution and incubate for
10 min at 37 �C.

3. Transfer multiple islets into 1.5 mL tube filled with trypsin LE
in 1� DPBS Tris-EDTA buffer NAC solution.

4. Incubate islets for 12 to 24 min at 37 �C.

5. Move all islets into a Petri dish coated with BSA and filled with
ice-cold 1�DPBS Tris-EDTA buffer NAC solution. Keep dish
on ice.

Fig. 2 Optical image processing and operations in microMS. A population of individual cells obtained from a
single human pancreatic islet is examined. (a) Examples of optical image views available through the
“switching image channels” option. The display of different image channels is controlled through the numeric
keys and is cycled with the T or Z keys. Orange arrow points toward two cell-like structures exhibiting
propidium iodide staining, indicative of cell damage. Such features are excluded from MALDI MS analysis. (b)
Image help menu describing multiple options available for image processing

136 Stanislav S. Rubakhin et al.



6. Move an individual islet into BSA-treated or low protein bind-
ing PCR tube filled with 50 μL of 1�DPBS Tris-EDTA buffer
NAC solution.

7. Mechanically dissociate islet in a tube using a BSA-treated cut
pipet tip attached to a 200 μL pipettor set to 50 μL.

8. Deposit three 500 μL droplets of 1� DPBS Tris-EDTA buffer
NAC solution onto a new marked ITO glass slide. Make sure
that the droplets remain separate.

9. Transfer solution with a cellular population formed during
pancreatic islet dissociation into one of 1� DPBS Tris-EDTA
buffer NAC solution droplets and agitate solution using careful
pipettor-generated liquid motions. This is needed for more
even distribution of cells on the ITO glass surface occupied
by the droplet.

10. Wait for 15–20 min for cells to sediment and stick to the ITO
glass slide’s surface. Visual control under a microscope using a
10� objective is instrumental for determination of the best cell
density and timing for the next step.

11. Fill a Pasteur pipet with ~1000 μL of the glycerol stabilization
solution.

12. Replace surrounding cells 1� DPBS Tris EDTA buffer NAC
solution with the glycerol stabilization solution by placing the
inlet of vacuum suction system at one side of 1� DPBS Tris-
EDTA buffer NAC solution droplet and adding the glycerol
stabilization solution onto another side.

13. Continue to use vacuum suction system to remove the glycerol
stabilization solution from the spot. Most of the solution
should be efficiently removed and glycerol-stabilized cells
stuck to the surface. Visible reduction in cell size can be
observed due to the hyperosmotic nature of the glycerol stabi-
lization solution. However, test measurements did not reveal
the presence of endogenous peptides or lipids in the glycerol
stabilization solution collected during this process. Addition-
ally, no loss of fluorescent staining is observed. Different con-
centrations of up to 40% glycerol w/v are used in mammalian
cell cryopreservation [47].

14. At this point, samples can be stored at 4 �C for several days,
preferably in a low oxygen environment. Other storage
approaches and durations should be tested experimentally for
their effects on cell integrity and biochemical profiles.

15. Remove samples from storage and acclimate them to ambient
conditions prior to optical imaging.

16. In most cases, some excess glycerol solution surrounding the
cells remains. Glycerol solution works as stabilizer but may
interfere with MALDI matrix deposition and crystallization
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processes as well as influence the results of brightfield optical
imaging. Therefore, remove this solution using one or two
15-s rinses with an appropriate solution, e.g., 150 mM ammo-
nium acetate in water [41]. Remove liquid excess with a stream
of nitrogen gas after each rinse. This improves the quality of
extracellular solution removal.

17. If needed, add aliquots of analyte standards mixed with
MALDI matrix solution onto marked spots on the ITO glass
slide. These spots are important for the mass spectrometer
calibration and batch mass spectra reprocessing conducted
and described in Subheading 3.2.

4.2 Islet Isolation

and Dissociation: Rat

Single Cell Populations

Rodent islet isolation is broadly covered in the literature [40, 48,
49]. The following is a brief description of the procedure used in
sample preparation for the outcomes described in Subheading 5,
Anticipated Results:

1. Fill syringe with 5 mL (of the 10 mL) prepared solution con-
taining collagenase P, BSA, and d-glucose. Preserve the
remaining 5 mL of the solution.

2. Use a guillotine to decapitate Sprague-Dawley rats.

3. Surgically open the abdominal cavity.

4. Apply a clamp at the point where the common bile duct merges
with the intestine, thus blocking liquid flow. Improper clamp-
ing will lead to incomplete fill of the pancreas with the diges-
tion collagenase P solution.

5. Inject the pancreas with the collagenase P solution at the
common bile duct Y junction, located between the liver lobes.

6. Dissect the pancreas and place into plastic tube with remaining
5 mL collagenase P solution.

7. Incubate the pancreatic tissues in a recirculating water bath for
20–30 min at 37 �C. A visually homogenous yellowish suspen-
sion should be formed. Taking several aliquots of suspension
during this treatment for examination under microscope is
helpful for determining the optimal duration of tissue exposure
to enzyme. Incomplete digestion will result in formation of
tissue pieces containing both acinar and islet cells. Over-
digestion coincides with a loss of islet integrity.

8. Shake tube gently every 10 min of the incubation period.

9. Wash resulting suspension twice with ice-cold mGBSS.

10. Centrifuge the suspension for 3 min at 300 g.

11. Remove and discard supernatant and resuspend pellet in 10mL
of ice-cold mGBSS.

12. Place resulting suspension into a plastic Petri dish.

138 Stanislav S. Rubakhin et al.



13. Place dish under inverted microscope and adjust illumination
to achieve islet appearing as brownish structures and acinar
tissue grayish or yellowish.

14. Under visual control using an inverted microscope, in within
10–20 min, manually isolate individual pancreatic islets using a
micropipet. Typically, only 20–30 pancreatic islets collected
from a single animal are needed for successful preparation of
10–15 single islet cell populations for microMS-based MALDI
MS analysis. If longer time is needed, DNAse (3000 U/mL)
should be added into the mGBSS where dissociation of pan-
creatic tissue is located to prevent clumping of acinar tissue
pieces and islets [50].

15. Place a single islet into 20 μL glycerol stabilization solution
containing Hoechst 33342.

16. Incubate for 2 h at 15 �C.

17. Triturate individual islets into single cells onto ITO-coated
glass microscopy slides creating a low-density cellular
population.

18. Repeat steps 15–18, described in Subheading 4.1.

4.3 Optical Imaging

of Cellular Populations

1. Perform tiled image acquisition using a fluorescent microscope
with sufficient magnification for the given cell type.

2. Each optical channel image should be preprocessed in ZEN for
optimal brightness and contrast before further processing,
including tile stitching and image export.

3. Images are processed using tile stitching algorithm available
in ZEN.

4. Resulting files are exported using conversion to bigTIFF [51]
format using ZEN software, blue edition.

5. For microMS, any optical image data processing and coordi-
nate finding, OpenSlide-supported image file format [52, 53]
is a suitable input; however, only Hamamatsu ndpi and big-
TIFF images have been thoroughly tested and are accepted by
default by microMS. For multichannel images, ndpi file names
should end with “Brightfield” (for channel 1, brightfield) and
“Triple” (for channel 2, RGB fluorescence). bigTIFF image file
name prefixes should not start with “8�” or “64�.” Multi-
channel bigTIFF image file names require the suffix “c#.tif”
where “#” is a digit between 1 and 9, typically corresponding to
an optical microscopy channel, e.g., brightfield at channel
1. ZEN creates a bigTIFF file for each optical channel and
names resulting file with user-defined names appended by
channel information, e.g., IsletCells_c1.tif and IsletCells_c2.
tif for two channels.
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4.4 Sample

Preparation for MALDI

MS Analysis

1. To achieve best results, immediately after image acquisition,
coat ITO glass slides with cellular populations with MALDI
matrix using the matrices, solvents, and matrix deposition
methods that are optimal for the research goal. Due to the
large variety of sampling approaches, study goals, and variabil-
ity in the equipment used, an evaluation set of samples should
be prepared and tested using several approaches as guided by
published information.

2. For detection of peptides in single cells, apply 50mg/mLDHB
dissolved in 1:1 (v/v) LC-grade ethanol/water with 0.1% TFA
using an automatic MALDI matrix sprayer.

!CAUTION Fiducial marks should be free of a MALDI
matrix layer because it may obstruct their visibility after loading
into the mass spectrometer.

3. If quantitative analysis is planned, apply aliquots of a solution
containing standards for targeted analytes on several marked
spots of the MALDI matrix-coated ITO glass slide. The analyt-
ical standard solution may include MALDI matrix, or you can
omit it if the solution solvents are capable of dissolving the
deposited MALDI matrix layer. Choose standard deposition
locations far from cell populations to avoid contamination.
Also, the locations should be easy to find after sample loading
into the mass spectrometer.

4. Generated samples can be stored at room temperature in a
desiccator or N2 environment for 24 h. Storage at lower tem-
peratures, e.g., 4 �C to �80 �C, helps to preserve biological
samples for different MS applications [54, 55]. It is important
to experimentally determine the optimal sample storage time
and conditions for each sample type. Reduction of sample
exposure to oxygen and excessive moisture, e.g., due to water
condensation on cold specimens, can be critical for successful
measurements.

4.5 Processing

Optical Images with

microMS: Finding Cell

Coordinates and

Output Filtering

Also, see the microMS manual: http://neuroproteomics.scs.
illinois.edu/microMS.htm, for more details.

1. Start microMS. On startup, the main GUI window is displayed
with the program icon and a second window for visualization of
the operational steps and errors (Fig. 1b).

2. Opening an image in microMS can be done in several ways,
depending on the image type, desired spatial resolution, and
procedure goal. Images that do not need to be magnified
during operation, e.g., images covering small areas, can be
loaded unmodified by selecting Open in the File menu
(or Ctrl + O). This will launch a file selection dialog that
prompts the user to select the desired file, which will subse-
quently be loaded. Selecting any image from a multichannel-
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data image set located in the same directory will open all
channels with matching filenames, as described above. Multiple
image channels (if they exist) are loaded at the same time and
overlaid on top of each other without image flattening. How-
ever, by default, non-pyramidal bigTIFF images can only be
zoomed out by 4�. bigTIFF images may be decimated to
8� and 64�, generating the sets of files “8 � <image
name>” and “64 � <image name>” with <image name>
being the name of original file (Fig. 1). This will enable further
zoom levels from 1� to 1/256� (which is recommended).

(a) bigTIFF image sets are decimated by selecting the Deci-
mate option in the File menu. Several options are avail-
able: both “Single Image” and “Image Group” options
are for the selection of one bigTIFF image. However,
when a single file of a multichannel-data image set (e.g.,
IsletCells_c1.tif) is selected with the “Image Group”
option, all images (e.g., IsletCells_c2.tif) of the set will
be decimated. The “Directory” option allows the selec-
tion of a single directory. All images contained in
sub-directories of the selected directory will be decimated.

(b) Notice that since a single image (brightfield) was deci-
mated, only the specified channel is displayed at higher
zoom levels. After decimation is complete, the process
does not need to be repeated the next time the image
set is opened. Opening the single non-decimated image
file through Open in the File menu will automatically load
the full image stack.

3. Use the image navigation features of microMS to visually
inspect loaded and displayed images. A list of mouse and key-
board controls are available through Help > Image Hotkeys
(Fig. 2). Depending on the size of the image and computer
performance, response time for these operations can be differ-
ent. Working with image files located on network drives or
USB2-connected devices may increase this time even further.

4. Perform previous step for all optical channels, switching
between image features available in microMS. The same list of
mouse and keyboard controls available through Help > Image
hotkeys can be used. As an example, displaying different images
for different optical channels is controlled through the numeric
keys and is cycled with the T or Z keys (Fig. 2a).

5. Determine the sample area(s) to be processed with microMS.
By default, the entire optical image area is subjected to proces-
sing. However, only a portion of the ITO glass slide is occupied
by cell populations. Therefore, to reduce processing time,
regions of interest (ROI) can be created on the analyzed images
so that finding of cell-like structures will be restricted to
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selected ROI. A single rectangular or polygonal ROI can be
created by holding Ctrl + left mouse button (LMB) and drag-
ging the cursor to form a yellow rectangle around the ROI. To
create polygonal ROI, a rectangular ROI should be drawn,
followed by its modification by (a) holding Ctrl + Alt,
(b) placing cursor nearby one of yellow side lines,
(c) dragging the cursor to a desired location leading to out-
lining of ROI with yellow, and (d) clicking of LMB to finalize
the modification. Polygonal ROIs also can be formed by hold-
ing Ctrl + Shift and consecutively clicking LMB and dragging
the cursor. The ROI can be removed by pressing the “c” key.

6. All structures detected on the images via user-defined parame-
ter settings in microMS are called blobs (cells and other stric-
tures). With optimal sample preparation, image acquisition,
and microMS parameter settings, most blobs will represent
individual cells. During the automatic blob finding process,
each blob has the following parameters determined: an x-y
coordinate, an effective radius, and the object’s circularity. To
start automatic blob finding, several blob parameters, such as
minimum size (in pixels), maximum size, minimum circularity
(shape), maximum circularity, threshold (lower threshold for
acceptable pixel signal intensity), image channel, and color,
should be imputed into Blob Find Entry window opened
through Tools > Blob Options (Ctrl + B).

(a) By default, image channel 1 corresponds to the brightfield
image. The intensity thresholding is done on one of the
RGB channels, allowing more specific and precise locali-
zation of the cellular features of a sample. Some of para-
meters can be left blank, e.g., maximum size and
maximum circularity.

(b) Activation of added parameters is done by clicking “Set
Parameters.” This will lead to automatic resizing of the
current image to maximal magnification and markup of
visible blobs detected according to the set parameters with
green circles. This option represents a quick way to deter-
mine the efficiency of the selected parameters. Visualiza-
tion of a different area of the image will lead to markup of
visible blobs with characteristics according to the set
parameters.

!CAUTION Different strategies can be used to optimize
the blob finding parameters, which are critical for determina-
tion of the coordinates for most of the individual cells. How-
ever, if the parameters are too strict, they may exclude a number
of sample structures from the next steps, such as distance
filtering. This may lead to mass spectra acquisition from several
closely located structures due to the relatively large laser beam
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footprint (e.g., 100 μm). Therefore, it is important to obtain
information on the localization of the maximum number of
structures before distance filtering, followed by removal of size-
incompatible features, e.g., large cell clusters or single nuclei
released from damaged cells. This challenge can be addressed at
the sample preparation stage when low-density populations of
intact single cells are deposited on the ITO glass slide.

7. To find cell-like structures (i.e., blobs) (Fig. 3), use Tools >
Blob Find to initiate finding according to set parameters. This
process can take from several seconds to several minutes. At the
end of the process, a window “Save All: Enter base filename”
pops up. Enter desired file name to save information on found
blob list in the .txt file located on the same directory where the
original images are located.

8. Visually examine the detected blobs, which will be outlined by
circles (Fig. 3b). For faster processing, only 150 blobs will be
outlined in the field view. To mark all blobs, uncheck Tools >
Limit Found Blobs. Alternatively, found blobs and other struc-
tures not selected as blobs but exhibiting above threshold
signal intensities can be visualized as uniquely color-coded
features on a dark blue background by pressing Shift + B,
activating/deactivating threshold view. Pointing the cursor to
a blob of interest and clicking on the middle mouse button will
generate information on its area and circularity in the status bar.
This information can be instrumental for optimization of the
blob finding process.

9. Create an additional blob list if unsatisfactory blob finding
occurs and if there is a need for comparison of different blob
lists. Up to ten different blob lists can be saved and quickly
compared. Alt + “the blob list number” will toggle different
already populated or empty blob lists. Choose an empty blob
list (0 blobs indicated in info line), change Blob Options, and
repeat the blob finding process; a new blob list and
corresponding file will be created and assigned chosen list
number. This process will result in the appearance of a new
set of marked blobs. Additionally, saved blob lists can be loaded
through File > Load > Found Blobs. All created blob lists can
be visualized using the key combination Shift + O. Overlapped
blobs will be marked by circles of blended colors.

10. If needed, filter blob list using ROI filtering. A ROI can be
created and blobs inside or outside of this ROI retained or
removed. Tools > ROI Filter Retain and Tools > ROI Filter
Remove are used in this procedure, which can be performed at
any time after blob finding. The ROI Filter Retain operation
removes all blobs outside of the specified ROI and moves the
resulting list to the next open blob list. The ROI Filter Remove
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Fig. 3 Examples of major steps in blob finding and selection as well as defining of fiducial marks. (a) Original
decimated three-channel overlay image of single human pancreatic islet cellular population. (b) Results of
blob finding procedure with minimal restrictions performed on blue channel image. Blobs are marked with
green circles. (c) Histogram window shows size distribution for all detected blobs. (d) Results of distance
filtering, cutoff at 100 pixels. Blob list #2 is automatically created. Blue and orange arrows point to related
displayed information. (e) Results of blob size filtering followed by histogram markup and filtering. Results of
manual single bar markup are shown in yellow. Blue bars of the histogram relate to blue circled blobs on the
image. The same is true for pink bars. Yellow lines point to two blobs corresponding to selected yellow bar.
Command “Apply filter” leads to formation of two new blob lists (from e): (f) list #4 for blue bars corresponding
cells and (g) list #5 for pink blobs. (h) Histogram and selected blobs for “Peak extremes” option of microMS;
200 blobs above and 200 blobs below the average are found and marked. (i) Example of manually added
markup of a fiducial point from the brightfield image. Images of small areas of one single cell population are
demonstrated. Orange arrows point to information line appearing after different calculation steps
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places all blobs outside the ROI into a new list. In both cases,
the original blob list is not modified and retains its number.

11. If needed, new blobs larger than 10 pixels are added to the
current blob list with a Shift + left mouse button (LMB) click.
Toggling of this key sequence will mark or unmark selected
blob. Shift + LMB click and dragging of cursor allows the user
to mark larger blobs. It is critical to manually create blobs at
ITO glass slide locations where analyte standards are deposited.
Mass spectra acquired from these sample areas can be used in
batch mass spectra reprocessing during the data analysis phase
detailed below.

12. If needed, perform filtering of blob lists using collected (during
automatic blob finding) information on blob size, circularity,
pairwise distance, and average signal intensity at chosen fluo-
rescence channel. Pairwise distance filtering is a recommended
first step, which allows detection and removal of blobs that are
too closely located for independent analysis by MALDI MS.
This and other filtering options are realized through the histo-
gram interface of microMS. Tools >Histogram Window (Ctrl
+ H) opens the graphic window (Fig. 3c, d). Shortcuts for
histogram navigation and function operations can be visualized
through Help > Histogram Hotkeys. The histogram will be
automatically updated after each operation, e.g., by switching
to another blob list or executed filtering. Tools > Histogram
Options leads to a pop-up window allowing a number of para-
meters for filtering to be selected, including image channel,
blob parameter (optical channel color or morphology: size,
circularity, or distance), offset (to the amount to increase
(>0) or decrease (<0) the blob radius when examining the
blob region), and level of optical signal intensity within the
outline of the blob. To save histogram information, use File >
Save > Histogram Image (.png file is generated) and File >
Save > Histogram Values (tab delineated text files containing
information on x-y coordinates and corresponding metric
value for each blob are saved). microMS has a number of
helpful functions for visual assessment of the results of
histogram-based filtering, including visualization of blobs
that correspond to a particular bar of the histogram using the
middle mouse button (MMB) to click on a single bar (Fig. 3e).
Vice versa, a LMB click on a blob will highlight the
corresponding bar. Clicking capital C as well as switching to
another blob list clears all histogram information. A right
mouse button (RMB) click on the histogram sets the upper
threshold for the filtered blob parameter (information on num-
ber of blobs above threshold is presented and responsible blobs
are color marked), and LMB sets the lower threshold (infor-
mation on number of blobs below threshold is presented and
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responsible blobs are color marked). For automatic finding of
peak extremes in a blob population, first select a range of bars
in the histogram using Shift + LMB (lower cutoff) and Shift +
RMB (upper cutoff) and then select Tools > Peak Extremes
(Fig. 3h). A pop-up window will allow the user to set the
number of blobs that will be searched for in high and low
ranges selected for the blob population.

13. In instances where several filters need to be applied for even
more selective defining of a targeted blob list, visually verified
filtering results should be consecutively saved as new blob lists
(Ctrl + A or Tools > Apply Filter) (Fig. 3f), or as new files
containing blob lists (File > Save > Histogram Divisions).

14. If needed, utilize the blob patterning feature of microMS for
analysis of large structures, such as multicellular pancreatic islet
aggregates or even entire islets. This option allows the user to
generate nine or more acquisition points per blob. Multipoint
signal acquisitions can produce better results than single-point
acquisition. Due to the focus of this protocol on single cell
analysis, please refer to the online microMS manual for more
details on this feature.

15. Save resulting blob lists using one of the following options:
(a) File > Save > Current Blobs (only current blob list is
saved), (b) File > Save >Histogram Divisions (saves informa-
tion on histogram filtered low- and high-intensity populations
as separate files), and (c) File > Save > All Lists of Blobs (all
blob lists are saved in separate files). Editable text files will be
created. Loading of saved blob lists using File> Load> Found
Blobs will overwrite current information, which should be
saved in advance if important.

4.6 High-Throughput

Single Cell MALDI MS:

microMS and Mass

Spectrometer

Information Co-

registration

1. Take sample coated with MALDI matrix from storage and, if
needed, acclimate to room temperature, preferably under
vacuum.

2. Load acclimated specimens into a MALDI TOF-TOF mass
spectrometer.

3. Using spots with calibrants, blank areas, and a test area with
cells deposited, create and optimize instrumental methods
appropriate for the experimental conditions and research
goals (Fig. 4).

4. To co-register the optical imaging information and the mass
spectrometer coordinates, run both microMS and the mass
spectrometer operating software (e.g., Bruker flexControl).

5. Ablate a single spot on the MALDI matrix-covered area of the
sample to visually determine the spot’s location on a video
output from the mass spectrometer. Mark this position for
easy finding during coordinate system alignment. The laser
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beam footprint position may change over time due to mechan-
ical misalignment that may occur during regular manual ion
source cleanup. Even a 50 μm shift may lead to significant
alteration of data output.

6. Load processed optical images for the sample under investiga-
tion into microMS. Only filtered blobs that have been targeted
for analysis should be circled on the microMS displayed image.

7. Choose the analysis instrument in microMS by selecting File >
Instrument. Several options are available by default, including
the Bruker ultrafleXtreme MALDI TOF-TOF and solariX
FTICR instruments.

8. Co-register the fiducial markers on the optical image displayed
in microMS and the same physical markers visible on the video
output from the mass spectrometer. Under visual control, align
the sample plate position and the first fiducial mark on the mass
spectrometer’s computer monitor where the laser beam
appears during acquisition. Find the same fiducial mark on
the image displayed in microMS and click RMB (Fig. 3i). A
pop-up window will appear asking the user to “Enter plate
coordinate”; the x-y coordinates of the sample plate aligned
in the mass spectrometer should be entered, e.g., 9494 3493,
where the first number is the x-coordinate and the second is the
y-coordinate, separated by a space. The actual sample plate
coordinates can be found in several places within the instru-
ment’s software. For example, for the ultrafleXtreme, flexCon-
trol displays this information in the Sample control window.
Copy and paste the displayed values into the pop-up window in
microMS and click OK. A blue circle marked with the letter and
number corresponding to the default plate spot numbering for
a Bruker MTP glass slide II adapter will appear. Move to
another fiducial mark in microMS, find the corresponding
fiducial on the mass spectrometer, and repeat the process.
More fiducial marks used for each ITO glass slide provides
enhanced coordinate alignment. At times an individual fiducial

Fig. 4 Mass spectrometry imaging-based testing of a sample area prepared for microMS-assisted analysis.
Cells are from a single human pancreatic islet. (a) Molecular image of distributions of three major pancreatic
islet hormones – glucagon (pink), somatostatin (red), and insulin (green). (b) The same image as in (a) with the
positions of laser sample probe shown. (c) The same as in (a) with distribution of MALDI matrix signal (yellow)
added

Image-Guided Single Cell MS 147



appears inconsistent with others; this is marked with a red circle
to indicate the fiducial with the worst alignment compared to
the other fiducial marks. If it appears there is an error in a
specific mark, this can be deleted by pressing RMB + Shift. It
is recommended to proceed to completion with the remaining
fiducial marks.

9. Save the co-registration information in microMS using File >
Save > Registration; a .msreg (mass spectral registration) file
will be created containing information on the instrument name
and fiducial set characteristics. The saved co-registration can be
loaded through File > Load > Registration.

10. Save the fiducial positions using File > Save > Fiducial Posi-
tions, producing an instrument-specific .xeo file with informa-
tion on fiducials. This file can be loaded into a mass
spectrometer to determine the accuracy of the co-registration
process.

11. Save the information on found and filtered, currently displayed
blob list using File> Save> Instrument Positions forming an .
xeo file. File is instrument-specific. During the save process,
three prompts will appear. The first allows the user to specify
file name and location. The second allows the user to set the
maximum number of blob positions that will be saved. The
third provides a choice between two options related to the
order in which blobs will be analyzed with MS. microMS
incorporates a simplified version of the traveling salesperson
path (TSP) optimization. The TSP approach determines the
minimum stage movements required to target all selected loca-
tions. Thus, choosing the TSP option significantly reduces the
sample plate movement time needed for analysis of all blobs.
However, there is a correlation between computer perfor-
mance, number of blobs, and time needed to calculate the
optimal path using the TSP algorithm. Considering that the
steps of this protocol, starting with co-registration of fiducial
marks, require mass spectrometer engagement, TSP calcula-
tions for very large blob lists may require more than the 3 min
allocated for this operation. Therefore, finding the optimal
number of blobs for such operation can be determined for
your specific computer system. Splitting of large blob lists
into several smaller ones by identifying ROI is one approach
to reduce the sizes of blob lists without compromising the
number of blobs analyzed. We have found that TSP is very
useful for most measurements.

12. It is a good idea to repeat the measurement of a small portion
each sample (Fig. 5). This test allows the user to determine if
the MALDI matrix and spatially co-localized analytes are
completely desorbed at each targeted cell. Incomplete use of
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sample/matrix in a single run suggests that one is not produc-
ing the best possible signals. However, it also creates an oppor-
tunity to reanalyze the same cells using different instrument
settings, including the use of MS2-based analyte sequencing.

4.7 High-Throughput

Single Cell MALDI MS:

Data Acquisition

Here we describe the procedures for a MALDI TOF-TOF mass
spectrometer (we used the Bruker ultrafleXtreme mass spectrome-
ter and software); similar procedures can be used for FTICR mass
spectrometers (e.g., the Bruker solariX).

1. Copy microMS-generated fiducial positions and the instru-
ment registration .xeo file into Data\Methods\GeometryFiles.

2. In flexControl, load the Method intended for analysis of
microMS-defined blobs.

Fig. 5 Test for completeness of MALDI matrix ablation during microMS-assisted high-throughput single cell
MALDI MS analysis. The same human pancreatic islet cells were analyzed twice. (a) Gel view of mass spectra
acquired twice from 498 cells. Arrows point to average mass spectra for all cells acquired during
corresponding set of acquisitions. The mass spectra are overplayed with gel views. (b) Results of PCA of
acquired data sets. (c) Receiver operator characteristic curves for selected analytes detected in repeated
measurements of the same sample
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3. Optimize acquisition parameters and calibrate the mass spec-
trometer using the Method and analyte standards deposited on
ITO glass slides.

4. Using flexControl, create an AutoXecute Method through the
Method: Edit option in the AutoXecute window. Use the
calibrated and optimized method during AutoXecute Method
creation. The number of laser shots per acquisition and laser
intensity used for an automatic run should be specified in the
AutoXecute Method. Importantly, if batch reprocessing of
acquired mass spectra are planned for the data analysis stage
(discussed below), also include and specify standard calibration
spots and flexAnalysis methods. These parameters are defined
during the Run Editor operation described in the following
steps.

5. Create a new run by selecting Run: New option in AutoXecute
window. The AutoXecute Run Editor window will pop
up. Choose File > New Run Wizard (Ctrl + Shift + N) to
open the New Run: Target geometry page. Mark Start with
wizard at this page. Find and mark the .xeo file. Hit Next; the
laser power tuning page will appear. Follow instructions on the
page and click Next. Calibration and sample spot selection page
will appear. Follow instructions by pointing, holding, and
dragging cursor from top left to bottom right corner of
empty space on the right side of the window. This will select
all microMS-determined blobs listed in the .xeo file. Hit Next.
The Run Parameter page will appear where the AutoXecute
Method, Data Destination: Data Directory, and Sample Name
should be specified. Keep lengths of both to a reasonable
minimum if peak list export into Excel spreadsheets is planned
(described below in Data Analysis and Processing sections).
More options are listed and can be used during the AutoXecute
run. Importantly, flexAnalysis MS and MS/MS methods
should be included in the AutoXecute run at this point to
allow some types of future batch mass spectra reprocessing, if
needed. (Consult the flexControl manual or Help for instruc-
tions.) Hit Next. A summary of the New Run Finish page will
appear. Click Finish. This will close the New Run Wizard.

6. In the remaining open AutoXecute Run Editor, click, hold, and
drag cursor, starting from upper left corner of unmarked empty
space located on the left upper side of the window. Releasing
the cursor at the right bottom corner will again mark all
microMS-determined blobs, which were invisible before this
selection step. Hitting OK opens the prompt for naming and
saving the AutoXSequence file. Saving the file results in closure
of the AutoXecute Run Editor and opens the window for
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Messages. This usually informs the user about Factory teaching
points; these cannot be loaded in case of custom teaching done
through co-registration of image file in microMS and the video
output of mass spectrometer. The Messages window can be
closed.

7. Hit Start Automatic Run in the AutoXecute window. Auto-
matic acquisition of data from all specified blobs will start. As a
result, the data directory specified during the New Run Wizard
procedures will be populated with folders containing individual
mass spectra.

4.8 Data Processing

and Analysis Using

ClinProTools

ClinProTools is a user-friendly program with an integrated set of
tools for biomarker discovery and clinical proteomics search. It
supports MS data post-processing and statistical profiling workflow
to detect biomarker patterns indicative of specific cell types. We find
the program help files and user manual informative regarding the
available analysis functions and guidelines on the choice of statistics.
Included below is an example of a workflow for a two-group
experimental comparison.

!CAUTION Mass accuracy of MS measurements depends on
many factors [56–58]. Therefore, before analysis of each data set,
determine if recalibration of the mass spectra is needed. The entire
data set or just representative mass spectra should be loaded into
ClinProTools (or flexAnalysis as described in the following section)
and precision and accuracy of measurements determined. Both
programs allow mass spectrum recalibration.

1. Split the entire data set into several new folders according to
the desired comparison traits. For example, we split 485 mass
spectra acquired from one pancreatic islet population into two
folders.

2. Set ClinProTools Data Preparation> Settings Spectra Prepara-
tion parameters.

3. Set Data Preparation > Settings Peak Calculation parameters.

4. Sequentially load two sets of mass spectra from the two differ-
ent folders into ClinProTools.

5. Using File > Save Class Paths, create an XLM file with infor-
mation on the location of all individual mass spectra loaded for
analysis.

6. Run Statistical Analysis > PCA. Confirm Scaling Method:
Level. New window with Score plots and Loading plots will
appear, and automatically selected peaks will be marked in the
mass spectra window. There are two main outputs of the analy-
sis. One is related to finding of characteristic profiles for
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different mass spectral groups corresponding to different cellu-
lar populations. Loading plots allow the user to determine
specific signals that contribute to profile differences among
cellular phenotypes. The other is the ability to export calculated
information on signal parameters into a table format, as
described below.

7. Save results in an Excel-compatible XML3 format using File >
Peak List Export option. This option also allows the user to
export information on all selected peaks in several other for-
mats. The XML3 format provides information on the class and
spectra paths as well as peak area and intensity as two separate
tables. Importantly, ClinProTools generates information on
intensity and area for all mass spectra, including ones that
have no peaks in the automatically selected m/z region. As a
result, the generated tables have no missing values, which are
typical for many types of mass spectrometric measurement out-
puts. This allows straightforward statistical analysis, including
sorting of mass spectra lists by biomarker information and
reloading of mass spectra sorted by groups into ClinProTools
for more detailed statistical analyses.

8. To open the XML3 file in Excel, a style sheet reference for
ClinProtPeakList.xsl should be found in C:\BDAL\ClinPro-
Tools_3_0\Files and copied to the same directory where the
XML3 file with results is located. When opening the file, a
pop-up with warning message about file format and extension
will appear and should be ignored by clicking “Yes.”

9. In most cases, signal intensity is one of the most common
parameters in the statistical analysis of MALDI MS-acquired
data. Therefore, choose Intensity table and perform data sort-
ing according to chosen biomarkers.

10. Evaluate individual mass spectra to determine the minimal
signal intensity for a particular biomarker and split the table
into two sections. Perform data sorting for another biomarker
in the remaining data set and repeat the steps above. As a result,
the entire data set will be divided into a number of classes
according to signal intensities of the chosen biomarkers.

11. Using the Excel CONCATENATE function, transform the
resulting table into a single column table with information
structured as follows:
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<ClinProtSpectraImport Version="0.0">

<Class Name="Class A">

<Element Path="C:\A\0_M16_1SLin\fid"/>

<Element Path="C:\A\0_M17_1SLin\fid"/>

<Element Path="C:\A\0_M18_1SLin\fid"/>

</Class>

<Class Name="Class B">

<Element Path="C:\B\0_M19_1SLin\fid"/>

<Element Path="C:\B\0_M20_1SLin\fid"/>

</Class>

</ClinProtSpectraImport>

where “Class A” can be replaced with custom name for the
data class and information on data path, e.g., “Y:\microMS
\Islet cells\1\0_x_17134y_16568\1\1SRef” enclosed in
parenthesis.

12. Save resulting table in Extensible Markup Language (XML)
file using Excel. Alternatively, the single column table can be
copied into the free software Notepad++ (https://notepad-
plus-plus.org/) for additional checking, formatting, and then
saving as an XML file.

13. Open newly created XML file in ClinProTools through File>
Open Spectral Import XML.

14. Perform new set of calculations, including PCA, pLSA, and
unsupervised clustering.

15. Export results through Reports option.

4.9 Data Processing

and Analysis Using

flexAnalysis

One drawback of using ClinProTools for a large number of mass
spectra is the need for significant data reduction, e.g., by a factor of
30–50. This leads to a noticeable reduction in mass resolution and
the accuracy of m/z values determined for each of detected com-
pounds. Therefore, complementary analysis of data sets can be
performed in flexAnalysis.

1. Open flexAnalysis and load representative mass spectra for all
predetermined classes.

2. Load mass spectra of analyte standards acquired during the
same set of measurements.
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3. Determine if mass spectra require recalibration. Sometimes
mass spectra acquired at different ITO slide locations require
recalibration, which can be done manually in flexAnalysis.
Unfortunately, no batch recalibration option is available unless
calibration mass spectra are included in the AutoXecute run
sequence.

4. Using Method > Edit Processing Method (Active Settings),
optimize Mass list and Processing parameters or use default
settings.

5. Perform Mass List > Find operation resulting in peak finding,
markup, and population of Mass List window with selected set
of parameters. A variety of individual signal parameters can be
chosen, including m/z, time-of-flight, signal intensity, signal-
to-noise ratio, quality factor, resolution, signal area, relative
intensity, full width at half maximum (FWHM), and
chi-square value.

6. The Export\Mass List to Excel command creates an individual
spreadsheet in a new Excel file for each reprocessed mass spec-
trum. Spreadsheets are automatically named with the directory
name containing the mass spectrum. Due to restrictions on the
length of spreadsheet names, some directory names are
truncated. The process of spreadsheet creation will stop when
a second identical name is generated. Therefore, it is strongly
recommended to keep the length of data set names to a rea-
sonable minimum. Additionally, with the availability of proper
data converters allowing access to proprietary data formats,
mass spectra generated by instruments of different vendors
can be converted into general formats such as mzXML, which
are readable by third-party software, e.g., MathWorks Mass
Spectrometry and Bioanalytics toolbox [59, 60]. Bruker’s
CompassXport is one such converter.

7. Use the Process Menu > Batch process macro for reprocessing
of multiple mass spectra. Mass spectra recalibration, baseline
correction, smoothing, normalization, and peak picking are
among the recommended reprocessing steps [61]. For large
sets of mass spectra, a data reduction procedure can be imple-
mented [62]. Mass spectra in a chosen folder, or those related
to particular AutoXecute run, can be selected for reprocessing.
Importantly, flexAnalysis MS and MS/MS methods should be
included when creating the AutoXecute run described above. A
variety of reprocessing functions can be performed in batch
mode, including mass spectra smoothing, peak picking, and
peak list export. flexAnalysis methods are editable through the
Method > Edit Script option. Multiple processes can be
included in a single flexAnalysis method.
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8. Correlate ClinProTools- and flexAnalysis-generated peak lists
and use the most accurate m/z values, which typically are
generated by flexAnalysis.

4.10 Ways to Assign

the Detected Signals

Typically, single cells contain insufficient material to allow struc-
tural characterization of multiple analytes using MALDI MS/MS.
Correlation to CE-ESI MS/MS or LC-ESI MS/MS data on iden-
tical tissue or bulk cell suspensions often provides more information
on the chemical identity of biological constituents. However, there
is often a partial overlap between ions detected by MALDI MS and
ESIMS, making direct comparison of data sets less straightforward.
There are several approaches available to help address this chal-
lenge. One option is a combination of single cell MALDI MS
data, published information on analyte presence in cells and related
tissues, and identifications from the LC-MS/MS data.

Alternatively, putative assignment of detected peptides can be
based on mass match to predicted peptides from known proteins
available in different databases such as UniProt [63, 64] and the
NCBI Protein Database [65]. In silico peptides should be calcu-
lated not only as typical monoprotonated [M + H]+ ions but also
frequently detected sodiated [M + Na]+ and potassiated [M + K]+

molecular ions typically detected by MALDI MS operating in
positive polarity mode. Steps for using UniProt to create a list of
putative ions for human islets of Langerhans, and NeuroPred, a
useful tool for prediction of prohormone/secreted protein post-
translational processing (http://stagbeetle.animal.uiuc.edu/cgi-
bin/neuropred.py) [66], are provided below.

4.10.1 Using UniProt 1. Go to https://www.uniprot.org/ and initiate search using key-
words related to annotation type and organism, e.g., annota-
tion:(type:peptide) organism:human. (Our search resulted in
454 entries with known endogenous peptides.)

2. To visualize information and links on peptides, use the “Col-
umns” option to add new non-default columns such as Pep-
tide, Transit Peptide, Modified residue, Post-translational
modification, and Disulfide bond.

3. Mark and copy entire area containing the search results and
paste it into an Excel spreadsheet. This information can be also
saved into a variety of formats (including Excel) via the
“Download” option. However, links and particularly useful
formatting in sub-tables will be lost.

4. Unmerge all columns in Excel and expand information on
Entry, Entry Name, Gene Name, and Protein Name specific
to each peptide to newly formed cells in corresponding
columns.
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5. Align in the same rows, information on Modified Residues and
peptides that have them. New columns may need to be added
because multiple modified residues are often present in the
same peptide.

6. Add an additional column for peptide sequences, e.g., “Peptide
Sequence,” which can be found by clicking on corresponding
links in the “Position(s)column. A new web browser BLAST
window will open, presenting information on the peptide
sequence.

7. Copy and paste this information into new “Peptide Sequence”
column.

8. When the “Peptide Sequence” column is populated, add new
column “Peptide Monoisotopic Mass.”

9. Download the NIST Mass and Fragment Calculator from
https://www.nist.gov/services-resources/software/nist-mass-
and-fragment-calculator-software.

10. Copy and paste entire “Peptide Sequence” column into
Sequence window of the Calculator. Select “Monoisotopic
mass of peptide sequence” and click “Formula.” A table con-
taining the Peptide formula, its monoisotopic mass, and
sequence will appear in lower window.

11. Copy and incorporate this table into the Excel spreadsheet.

12. Create a list of putative ions by adding to or subtracting from
peptide monoisotopic mass values associated with PTMs spe-
cified in the table, as well as proton, sodium, and potassium
adducts. Information on monoisotopic masses for these entries
can be found at several locations including https://www.
uniprot.org/docs/ptmlist and https://fiehnlab.ucdavis.edu/
staff/kind/metabolomics/ms-adduct-calculator/. This proce-
dure will create at least three m/z entries for each peptide. Pay
attention to peptides that have two chains linked by disulfide
bonds, e.g., insulin. Only separate chains are listed in the
Peptide tables. Therefore, their combined monoisotopic
masses should be calculated and corresponding PTM and
ion-forming modifications calculated.

13. Create a combined table of putative and measured peptides.
Sort all entries and find close to identical m/z values.

14. If all ions cannot be identified using UniProt, test the informa-
tion on identified peptides using the peptide mass fingerprint-
ing [66–68] approach [64, 65, 67] for protein identification.
Several open-source modeling tools are available on the Pro-
teinProspector portal https://prospector.ucsf.edu.
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4.10.2 Using NeuroPred The basic steps are outlined below, with detailed instructions avail-
able on the NeuroPred site. There is no batch processing option in
NeuroPred, and predictions can be made for individual
prohormones.

1. Use the FASTA sequence format to paste the protein of interest
into The Sequence Submission Box of NeuroPred http://
stagbeetle.animal.uiuc.edu/neuropred/neuropredinput.
html#sequenceformat).

2. Fill the prediction parameters box as desired (include signal
peptide length, PTMs of interest, etc.). Importantly, select a
relevant animal model for your search before submitting the
search. In our case, we selected the Mammalian prediction
model.

3. NeuroPred will generate a list of theoretically possible peptides
resulting from endogenous enzymatic prohormone processing
according to known cleavage rules observed in mammals. Note
that resulting list of putative processed peptides needs addi-
tional sorting upon export in Excel to remove peptides with
untrimmed basic residues and products of missed cleavage
(if this option was enabled during setup).

4. Combine all tables, perform additional data sorting, and per-
form additional search.

5. Ambiguous mass matches to predicted peptides can be vali-
dated by modeling the isotopic cluster of predicted sequence
against experimentally observed peptide isotopic envelop pat-
tern. In flexAnalysis, this can be achieved by using the Smart-
Formula function.

5 Anticipated Results

microMS-supported high-throughput single cell MALDI MS pro-
vides individual profiles on populations of thousands of cells.
Because of the nature of MALDI MS and the low amounts of
material within a cell, only the most abundant analytes are detected,
while assessment of large populations enables statistical compari-
sons and insights into cellular heterogeneity. For example, within
the populations of individual cells from rodent pancreatic islets,
peptide profiles representing the expected cell types (α, β, δ, and
PP cells) containing the canonical islet peptides are detected
(Fig. 6a) [32]. The approach described here allows detection of
more than 300molecular futures in the 1000–7000molecular mass
range among individual cells. With optimal sample preparation and
tuning of the MALDI TOF-TOF mass spectrometer, even a single
cell sample can generate mass spectra of higher molecular weight
peptides at >8 kDa with a mass resolution and accuracy from sub
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ppm to single digits (Fig. 6b, c). However, the relative intensity of
signals varies between cells. A number of rare observations have
included putative multiple oxidation of glucagon (Fig. 6d) and
dimerization of somatostatin 14 (Fig. 6a). Both biological and
experimental reasons for signal variability should be investigated
further.

As mentioned above, image-guided single cell MALDI MS
analysis is capable of providing information on the chemical hetero-
geneity of cellular populations. Proper data processing and analysis
are critical for this evaluation. Dispersing a cellular population on
an ITO glass surface leads to loss of information on tissue localiza-
tion, e.g., known localization of β-cells in the islet core surrounded
by inhomogeneous layers of α, δ, and PP cells [69]. Therefore,
detected chemical biomarkers are becoming major guiding factors
for cell-type determination. Importantly, other approaches for cell-
type determination before or after MALDI MS analysis can be used
in conjunction with microMS, including immunostaining
[36]. Such biomarkers can be predicted using published informa-
tion or direct data set analysis. As an example, a data set acquired

Fig. 6 Results of microMS-assisted MALDI MS analysis of a single rat pancreatic islet cell population. (a)
Examples of mass spectra acquired from eight cells representing main cellular types in the pancreatic islets.
(b) Mass spectrum demonstrates insulin 1C and insulin 2C peptide signals with mass resolution and error
indicated. (c) Mass spectrum demonstrating insulin 1 and insulin 2 signals with mass resolution and error
indicated. (d) Mass spectrum demonstrating putative multiple oxidation of glucagon. Intens. – relative
intensity of signals. (a.u.) – arbitrary units. “Error” in ppm is a deviation between the measured mass and
the theoretical mass of the selected peak. “Error” is calculated using “SmartFormula Manually” option in
flexAnalysis. “Resolution” is mass resolution calculated as part of “Mass list” parameters in flexAnalysis
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from a cellular population of a single rat pancreatic islet was split
into two and evaluated using unsupervised PCA (Fig. 7a–c).
Related loading plots revealed compounds that affected the diver-
sity of cellular populations most with Load2 vs. Load3 exhibited
two major influences – signals for glucagon and insulin – which
were accompanied by other related compounds (Fig. 7b). As
expected, score plots did show minor differences between the two
populations. Such differences can be important to determine sam-
ple inhomogeneity related to experimental or biological factors.
Influences of experimental factors, such as gradients in the
MALDI matrix layer thickness or localized sample contamination,
have to be evaluated to exclude their detrimental effects on
measurement results. However, this approach needs further devel-
opment in terms of cell-to-cell reproducibility (which may be
biology-, sample preparation-, or MS measurement-related). Nev-
ertheless, the molecular signatures enable classification of the entire
data set into groups related to known cell types (Fig. 7d). This step
helps not only to group cells but also to remove cells that exhibit

Fig. 7 Chemical cellular heterogeneity of rat pancreatic islets via microMS-assisted MALDI MS analysis. (a)
Gel view of mass spectra acquired from cellular population of a single pancreatic islet divided into two data
sets. (b) PCA of the data sets with loading plots demonstrating co-localization of signals related to different
cell types, e.g., insulin (I)- and glucagon (G)-expressing cells. (c) Average mass spectrum for both data sets
with signals automatically picked by ClinProTools (blue lines). (d) Gel view of filtered and grouped by listed
above biomarkers and somatostatin 14 (S) entire set of mass spectra. (e) Results of PCA of three data sets
formed by biomarker-guided filtering and grouping of entire set of mass spectra. (f) Histograms of relative
intensities of somatostatin 14 (class 1) insulins 1 and 2 (class 2), and glucagon (class 3) signals detected in
cells of different types. (g) Distributions of relative signal intensities at m/z areas of somatostatin 14 (S),
glucagon (G), insulin 1 C-peptide (C1), insulin 2 C-peptide (C2), pancreatic polypeptide (PP), insulin 1 (I1), and
insulin 2 (I2). These distributions were determined during ClinProTools analysis of mass spectra of cellular
populations obtained from five individual rat pancreatic islets (marked on x-axis as class 1–5)
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higher levels of chemical cross-contamination, increasing the reli-
ability of the data analysis. Perhaps dissociation of islets into single
cell populations may coincide with loss of cell integrity and release
of intracellular analytes. This is noticed when mixed mass spectra
are acquired. In such mass spectra, characteristic molecular peaks
for distinct cell types may co-localize. As an example, a weak insulin
signal is observed in α cells (orders of magnitude weaker than in β
cells), but insulin is not observed in δ cells (Fig. 7d). Reanalyzing
grouped data sets by supervised PCA demonstrated expected sepa-
ration of three cell types and provided more information on associ-
ation of unidentified signals with known cell types (Fig. 7e).
Additional statistical output on all associated molecules can be
generated (Fig. 7f). Extension of image-guided MALDI MS analy-
sis to cellular populations of different pancreatic islets demonstrates
the variability of their cellular composition (Fig. 7g). As expected,
the frequency of detection of β cell-related biomarkers, such as
insulins 1 and 2, as well as their C peptides, is highest in all five
examined islets. However, only one islet demonstrated cells with
strong somatostatin 14 signals, and another islet exhibited a large
number of insulin-producing cells but a small number of glucagon-
expressing cells. Ratios of relative intensities for insulin 1/insulin
1C peptide and insulin 2/insulin 2C peptide are similar for each of
the examined pancreatic islets, which is indicative of good repeat-
ability of measurements. These results corroborate well with previ-
ous findings on the cellular heterogeneity of pancreatic islets
[69, 70]. We expect similar results are possible on many other cell
types.
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